Resolved Just tested Windows 1.4.9 and found 4K screen support has stopped working

Just tested Windows 1.4.9 and found 4K screen support has stopped working as it did in 1.4.8. The scene when logged in is fuzzy and I am guessing at around 720p? The start-up screen is also probably a clue. I had to shrink screenshotDayturn not 4K now.PNG as 'too large to upload' at 144 dpi so reduced to 72 dpi.
 

Geir Nøklebye

World Builder
Staff member
Go to the Edit menu and set a screen size. (you can type in the scene size manually)
When I use retina resolution in the vmware virtual machine I have to select double size to get a normal size viewer.

Note that for the startup screen, the web-view will not scale to the edges over a certain resolution.
 
OK I'll try that. Weird that in previous version it just worked and I changed nothing, even start-up screen was full screen.

Wow, you run in a VM! VMware Fusion or Parallels? I use VMWare, in fact, I have my full Mojave startup disk now in a VM in case Catalina fails on something I need. That was a fun ride thanks to Catalina's new APFS setup.

OK UPDATE: Edit/ size was already correct at Ultra 4K yet low res continues.
 

Geir Nøklebye

World Builder
Staff member
Yeah, I build the windows version in vmware Fusion, which works OK up to a certain point as it is impossible to test everything as you can on real HW.

I just had to build a high sierra vm too for an application in which I have data going back 14 years, and that cannot run on anything newer.
 
OK UPDATE: Edit/ size was already correct at Ultra 4K yet low res continues. I tried setting to 2560 x 1440 and starting and then quitting and resetting to 3840 x 2160 in case it was sticking, but no luck, Still low rez on entering inworld.
 

Geir Nøklebye

World Builder
Staff member
That is very strange as there is no code change that remotely touch the screen scaling code.

This version is built with VS2013 Community and the previous with VS2013 Express. There might be something there...

Having said that, the screen resolution handling code on Windows 10 is a recurring issue with patches from LL ever so often to fix it once and for all (yeah right).
 
I'll reboot the PC, I trust Windows as far as I could throw my Dell T110 II server (that's about 2 feet straight down lol).
 
Dayturn RLV 1.4.9 (45201) Oct 12 2019 13:05:30 (Release)


Release Notes





You are at 128.0, 128.0, 22.1 in Avatar Welcome located at (47.204.52.248:8041)


SLURL: hop://mikeland.ddns.net:8002/Avatar%20Welcome/128/128/22


(global coordinates 256,128.0, 256,128.0, 22.1)


In region Avatar Welcome at (1000, 1000)


OpenSim 0.9.1.0 Snail Dev (Win/.NET)





CPU: Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz (3192 MHz)


Memory: 32575 MB


OS Version: Microsoft Windows 8 64-bit (Build 9200)


Graphics Card Vendor: NVIDIA Corporation


Graphics Card: GeForce GTX 1080/PCIe/SSE2





Windows Graphics Driver Version: 23.21.0013.8813


OpenGL Version: 4.6.0 NVIDIA 388.13





Window size: 3840x2066


Font Size Adjustment: 96pt


UI Scaling: 1


Draw distance: 1024m


Bandwidth: 4096kbit/s


LOD factor: 8


Render quality: 6


Advanced Lighting Model: Enabled


Texture memory: 2048MB


VFS (cache) creation time: September 21 2019 17:36:48





RestrainedLove API: Disabled


J2C Decoder Version: OpenJPEG: 1.4.0, Runtime: 1.4.0


Audio Driver Version: FMOD Ex 4.44.64


LLCEFLib/CEF Version: 1.5.3-(CEF-WIN-3.2526.1347-32)


LibVLC Version: 2.2.4


Voice Server Version: Vivox





Built with MSVC version 1800


Packets Lost: 0/3,230 (0.0%)


October 12 2019 12:23:24
 

Geir Nøklebye

World Builder
Staff member
Cause the RLV version could very well be more icky for high resolution as it does all kind of weirdness in order to enable blocking the view in lockdown mode.
 

Geir Nøklebye

World Builder
Staff member
What exactly is fuzzy? Is the in-world textures, are mesh items jagged, are ground textures fuzzy? Is the UI crisp or fuzzy?
 

Geir Nøklebye

World Builder
Staff member
So everything is low rez...

Can you clear the cache and restart, as there is one change that has to do with how directory names are read in Windows.
 
Sorry, no change after clearing cache, quitting and restarting. This still non RVL 2.4.9. Anything worth changing in the Graphics options?
 

Members online

No members online now.
Top