Using YEngine script engine on the PI with OpenSim 0.9.1

Geir Nøklebye

World Builder
Staff member
There has been some questions about the YEngine script engine released in OpenSim 0.9.1 where people have had issues making it run.

In an initial casual test (not testing the YEngine itself) OpenSim 0.9.1 Linux binary version was downloaded and unpacked on a PI 4B.
Then the ARM binaries was applied to the bin folder with the accompanying config files.
Finally ubOde physics was enabled, Bulletsim disabled, YEngine enabled and XEngine disabled in the default OpenSim.ini file.

Running mono --server OpenSim.exe in terminal started OpenSim with YEngine without any issues.

This was tested on mono 6.4.0.198 and Linux 4.19.75-v8+ #1270 SMP PREEMPT Tue Sep 24 18:59:17 BST 2019 aarch64 GNU/Linux
 

Members online

Top